summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-01-05 10:32:33 +0200
committerEfraim Flashner <[email protected]>2025-01-05 14:53:50 +0200
commite70de850fc1ecc1a8bcde3385661c283751734e4 (patch)
treed1634048b5281b88c170fd4b7ff892778a61fa66 /gnu
parent8166de494751dc2f3e1a44a59e4aedca9af7e624 (diff)
gnu: ncdu-1: Update to 1.21.
* gnu/packages/ncdu.scm (ncdu-1): Update to 1.21. [arguments]: Add a configure-flag to set the fallback shell. [native-inputs]: Add pkg-config. [inputs]: Add bash-minimal. Change-Id: Iee357abefad7f44141ff00c9235cf25ef2d04f96
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ncdu.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/ncdu.scm b/gnu/packages/ncdu.scm
index 6356470467..5a713ee444 100644
--- a/gnu/packages/ncdu.scm
+++ b/gnu/packages/ncdu.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <[email protected]>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <[email protected]>
-;;; Copyright © 2022-2024 Efraim Flashner <[email protected]>
+;;; Copyright © 2022-2025 Efraim Flashner <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,6 +20,7 @@
(define-module (gnu packages ncdu)
#:use-module (gnu packages)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages compression)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
@@ -38,16 +39,23 @@
;; yet, so we'll keep both for just a little longer.
(package
(name "ncdu")
- (version "1.20")
+ (version "1.21")
(source (origin
(method url-fetch)
(uri (string-append "https://dev.yorhel.nl/download/ncdu-"
version ".tar.gz"))
(sha256
(base32
- "0wlmpq8gzcl1fim8jba3g0q0bbn4jcrbkns2n95kfwmy3a2bpqjz"))))
+ "19h1jvgiw7dvpxlhg6sqzc1c8gjkaj7z9girc255gkkbnjlx7558"))))
(build-system gnu-build-system)
- (inputs (list ncurses))
+ (arguments
+ (list #:configure-flags
+ ;; Configure default shell for spawning shell when $SHELL is not set
+ #~(list (string-append "--with-shell="
+ #$(this-package-input "bash-minimal")
+ "/bin/sh"))))
+ (native-inputs (list pkg-config))
+ (inputs (list bash-minimal ncurses))
(synopsis "Ncurses-based disk usage analyzer")
(description
"Ncdu is a disk usage analyzer with an ncurses interface, aimed to be