summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorWilko Meyer <[email protected]>2023-12-18 18:03:03 +0100
committerNicolas Goaziou <[email protected]>2025-03-09 17:37:00 +0100
commitdf289cd9ee380672141cf7292838ecc668036aba (patch)
tree7fc1f1127958f346d98491487b8790f9a45bdcaa /gnu
parente0d0faa8b98615dcbcfc020e961ddfd9054ce4dd (diff)
gnu: Add perl-b-utils.
* gnu/packages/perl.scm (perl-b-utils): New variable. Change-Id: I9c479152dcceb8d78900f7ef482d2bd7280d8401 Signed-off-by: Nicolas Goaziou <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2b9fde53cf..15c6b6d302 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -995,6 +995,26 @@ compiling the surrounding scope.")
(description "This module allows you to wrap OP check callbacks.")
(license (package-license perl))))
+(define-public perl-b-utils
+ (package
+ (name "perl-b-utils")
+ (version "0.27")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/B-Utils-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1spzhmk3z6c4blmra3kn84nq20fira2b3vjg86m0j085lgv56zzr"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-extutils-depends))
+ (propagated-inputs (list perl-task-weaken))
+ (home-page "https://metacpan.org/release/B-Utils")
+ (synopsis "Helper functions for op tree manipulation")
+ (description "@code{B::Utils} provide helper functions for op
+tree manupulation.")
+ (license license:perl-license)))
+
(define-public perl-b-keywords
(package
(name "perl-b-keywords")