summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <[email protected]>2025-02-11 16:13:05 +0000
committerIan Eure <[email protected]>2025-02-11 12:46:22 -0800
commitd5d3cb2c15abed37577b150cbf1479a01145e8bf (patch)
tree81f1a76750750eae0b5dd93b68933e36a0727459 /gnu
parent27ae526fd8d0ece5abe7c1207b419c50d1f6ccae (diff)
gnu: xonsh: Fix tests.
The two failing tests are in tests/completers/test_pip_completer, so rather than exclude the tests instead add the native input. * gnu/packages/shells.scm (xonsh)[native-inputs]: Add python-pip. Change-Id: Ide457ffca0e05d03d9d4d3fea36c1d23a2257c27 Signed-off-by: Ian Eure <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shells.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 7763c2729b..6f830d54aa 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -620,6 +620,7 @@ ksh, and tcsh.")
(setenv "HOME" "/tmp"))))))
(native-inputs
(list git-minimal
+ python-pip
python-pyte
python-pytest
python-pytest-mock