summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2023-04-18 16:24:30 +0300
committerEfraim Flashner <[email protected]>2023-04-18 16:27:41 +0300
commitcf953e4c274c00dcd8a32a8823f7b44a7c73b126 (patch)
tree4fb16d9ff9699d1115fec8cc74bb9df9a665081f /gnu
parent3a67775154e7a263063063187a80bcfdf1218b0e (diff)
gnu: openmw-scenegraph: Fix build.
* gnu/packages/graphics.scm (openmw-scenegraph)[outputs]: Only use 'out' output. [arguments]: Delete inherited 'copy-plugins phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 12b6c94932..27f62ea867 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Tomáš Čech <[email protected]>
;;; Copyright © 2016, 2019 Leo Famulari <[email protected]>
;;; Copyright © 2016, 2017, 2019 Ricardo Wurmus <[email protected]>
-;;; Copyright © 2016, 2018, 2021 Efraim Flashner <[email protected]>
+;;; Copyright © 2016, 2018, 2021, 2023 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Andreas Enge <[email protected]>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <[email protected]>
;;; Copyright © 2017, 2018 Ben Woodcroft <[email protected]>
@@ -1473,6 +1473,7 @@ in Julia).")
(package
(inherit openscenegraph)
(version (git-version "3.6" "1" commit))
+ (outputs (list "out"))
(source
(origin
(method git-fetch)
@@ -1498,7 +1499,10 @@ in Julia).")
"-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
;; The jpeg plugin requires conversion between integers and booleans
"-DCMAKE_CXX_FLAGS=-fpermissive")
- #$flags))))))))
+ #$flags))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (delete 'copy-plugins)))))))))
(define-public povray
(package