summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLuis Guilherme Coelho <[email protected]>2025-03-06 21:18:04 -0300
committerLudovic Courtès <[email protected]>2025-03-10 00:38:05 +0100
commitc3dd3b8465c7520353542659aa836408325099ea (patch)
treee1a9fe2cf5c1ddc1555ec3350409bd126d5d20c1 /gnu
parentb25af7d8131547ca531521e357fb802db23c1b4e (diff)
gnu: fish: Add support for guix home profile.
* gnu/packages/shells.scm (fish)[arguments]<#:phases> {patch-fish-extra-paths}: Add `~/.guix-home/profile' to `__guix_profile_paths'. Change-Id: If896cfc4f948d86c52073235a6f4a2c1d085e7a6 Signed-off-by: Ludovic Courtès <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shells.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 63bdf69705..e177a90de0 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -223,10 +223,10 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
(string-append
"\n\n"
"# Patched by Guix.\n"
- "# Enable completions, functions and configurations in user's"
- " and system's guix profiles by adding them to __extra_*"
+ "# Enable completions, functions and configurations in user's,"
+ " home's and system's guix profiles by adding them to __extra_*"
" variables.\n"
- "set -l __guix_profile_paths ~/.guix-profile"
+ "set -l __guix_profile_paths ~/.guix-profile ~/.guix-home/profile"
" /run/current-system/profile\n"
"set __extra_completionsdir"
" $__guix_profile_paths\"/etc/fish/completions\""