summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJaeme Sifat <[email protected]>2023-12-19 22:55:11 -0500
committerEfraim Flashner <[email protected]>2024-02-20 13:56:46 +0200
commitc1f492216bdbe24eae970e45f0313768966b7d4a (patch)
tree7af7888838276c642538555bf9c5df66de79522c /gnu
parentad70bfd724f804dc7bacb0511b77312dedece204 (diff)
gnu: Add rust-palette-derive-0.7.
* gnu/packages/crates-graphics.scm (rust-palette-derive-0.7): New variable. Change-Id: I0d4341fc5140ab62fccfee6b5e68d37ba4788f92 Signed-off-by: Efraim Flashner <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-graphics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 583a87b898..a4b8e321b2 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1892,6 +1892,29 @@ graphics and video games.")
(description "This package provides OSMesa library bindings for Rust.")
(license license:cc0)))
+(define-public rust-palette-derive-0.7
+ (package
+ (name "rust-palette-derive")
+ (version "0.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "palette_derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "02ps239sxcr5v294qf89d87sv7fdm9pr2cziwj2l6ggzql703nxp"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-find-crate" ,rust-find-crate-0.6)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-2))))
+ (home-page "https://github.com/Ogeon/palette")
+ (synopsis "Automatically implement traits from the @code{palette} crate")
+ (description "This package allows automatically implements traits from the
+@code{palette} crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-piston-float-1
(package
(name "rust-piston-float")