summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorThanos Apollo <[email protected]>2025-02-28 13:39:42 +0200
committerLudovic Courtès <[email protected]>2025-03-08 18:11:29 +0100
commitbe49b0f4435cf1d9275cbbc9cac3a84fa4478ff9 (patch)
tree4429a7be890be1b6d727a93737b49deb97a0cba0 /gnu
parentf7cf9fbec786e0e4b33ca2c56fd9e0dda824eb38 (diff)
gnu: Add hunspell-dict-el-polytonic.
* gnu/packages/hunspell.scm (hunspell-dict-el-polytonic): New variable. Change-Id: I18112b9f36f66160dc540defac03a7f2ed9eed2d Signed-off-by: Ludovic Courtès <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/hunspell.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/hunspell.scm b/gnu/packages/hunspell.scm
index d19b2aff01..040c1a33f9 100644
--- a/gnu/packages/hunspell.scm
+++ b/gnu/packages/hunspell.scm
@@ -365,6 +365,39 @@ spell-checking library.")
(home-page "https://git.thanosapollo.org/hunspell-dict-el/")
(license (list license:gpl2 license:gpl3)))))
+(define-public hunspell-dict-el-polytonic
+ (let ((commit "ddb787b6a28767773ff2b6ed0092a6957e4825e3"))
+ (package
+ (name "hunspell-dict-el-polytonic")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.thanosapollo.org/hunspell-dict-el-polytonic")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ik14rcpxxmp35314rcip38nr0z8i3375l5k9ajf6ywx8r5i3zr9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'build)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (share (string-append out "/share/hunspell/")))
+ (install-file "el_GR.aff" share)
+ (install-file "el_GR.dic" share) #t))))
+ #:tests? #f))
+ (native-inputs (list hunspell ispell perl))
+ (synopsis "Hunspell Polytonic Greek/Hellenic dictionary")
+ (description "This package provides a dictionary for the Hunspell
+spell-checking library.")
+ (home-page "https://git.thanosapollo.org/hunspell-dict-el-polytonic")
+ (license (list license:gpl2 license:gpl3)))))
+
(define* (hunspell-dictionary dict-name full-name #:key synopsis home-page license)
(package
(name (string-append