summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorspacecadet <[email protected]>2025-03-09 16:19:34 +0100
committerNicolas Goaziou <[email protected]>2025-03-09 16:22:27 +0100
commitbe08c1d70d7d0e396b7fa8ac48d444517b25e33f (patch)
tree6b78b79e92aca1f0a5af9e4cbcbe7e1d79af1060 /gnu
parentc4f297a664869a18126b66eb5209de1fcceb42d8 (diff)
gnu: drawpile: Update to 2.2.2-beta.5.
* gnu/packages/graphics.scm (drawpile): Update to 2.2.2-beta.5. [inputs]: Add libwebp, miniupnc, vulkan-headers, qtbase, qtmultimedia, qtsvg. Remove qtbase-5, qtmultimedia-5, qtsvg-5. Change-Id: I8544efa9ba722ab7ce962ee4a972eb16b6ed682e Signed-off-by: Nicolas Goaziou <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm80
1 files changed, 41 insertions, 39 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 97a40293cb..9d7ec2933a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2522,44 +2522,46 @@ Automated palette selection is supported.")
(license license:expat)))
(define-public drawpile
- ;; This commit fix building with libmicrohttpd>=0.71.
- (let ((commit "ed1a75deb113da2d1df91a28f557509c4897130e")
- (revision "1"))
- (package
- (name "drawpile")
- (version (string-append "2.1.17-" revision "." (string-take commit 9)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/drawpile/Drawpile")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1y21h1hk9ipkjvhjgas0c5hkjyan92vsxbxrn60c906hzqln2fr1"))))
- (build-system qt-build-system)
- (arguments
- '(#:configure-flags
- (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")))
- (native-inputs
- (list extra-cmake-modules pkg-config))
- (inputs
- (list giflib
- karchive-5
- kdnssd-5
- libmicrohttpd
- libsodium
- libvpx
- libxi
- ;; ("miniupnpc" ,miniupnpc) ;segfaults for some reason
- qtbase-5
- qtkeychain
- qtmultimedia-5
- qtsvg-5
- qtx11extras))
- (home-page "https://drawpile.net")
- (synopsis "Collaborative drawing program")
- (description "Drawpile is a drawing program that allows share the canvas
+ (package
+ (name "drawpile")
+ (version "2.2.2-beta.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/drawpile/Drawpile")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1w6vfdm6rmnpn6s8kzm8blbaidlsg8q6spv95m7fnwr3984hf6hb"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:qtbase qtbase
+ #:configure-flags
+ #~(list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")))
+ (native-inputs
+ (list extra-cmake-modules pkg-config))
+ (inputs
+ (list giflib
+ karchive
+ kdnssd
+ libmicrohttpd
+ libsodium
+ libvpx
+ libwebp
+ libxi
+ libxkbcommon
+ libzip
+ miniupnpc
+ qtbase
+ qtkeychain
+ qtmultimedia
+ qtsvg
+ qtx11extras
+ vulkan-headers))
+ (home-page "https://drawpile.net")
+ (synopsis "Collaborative drawing program")
+ (description "Drawpile is a drawing program that allows share the canvas
with other users in real time.
Some feature highlights:
@@ -2575,7 +2577,7 @@ Some feature highlights:
@item Encrypted connections using SSL
@item Automatic port forwarding with UPnP
@end itemize\n")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public openxr
(package