summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2024-12-29 17:35:44 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:28 +0100
commitbd86c2c28e7607f6a794dbdbff07385d004979cf (patch)
treeba4eb862ae88a360004ca4909f66f514a9e64c3c /gnu
parent4c0dbecfcfe7cd4f16ac06bd24e4da27adb98cef (diff)
gnu: python-dnspython: Disable ECDSA tests.
* gnu/packages/python-xyz.scm (python-dnspython)[arguments]: Disable four tests. Change-Id: Ia8dad056dca0842cd709180c0819d595b171b18b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f497c97536..61f2955ee0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22967,7 +22967,13 @@ until the object is actually required, and caches the result of said call.")
;; AssertionError: assert False
"--deselect=tests/test_features.py::test_have"
;; dns.exception.SyntaxError: protocol not found
- "--deselect=tests/test_rdata.py::RdataTestCase::test_misc_good_WKS_text")
+ "--deselect=tests/test_rdata.py::RdataTestCase::test_misc_good_WKS_text"
+ ;; ECDSA with deterministic signature (RFC 6979) is not supported by
+ ;; this version of OpenSSL.
+ "-k" (string-append "not testDeterministicSignatureECDSAP256SHA256"
+ " and not testSignatureECDSAP256SHA256"
+ " and not testSignatureECDSAP384SHA384"
+ " and not test_ecdsa"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-getprotobyname-calls