summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-10 08:39:02 +0000
committerSharlatan Hellseher <[email protected]>2025-02-10 08:39:10 +0000
commitbb273fc1a0dcfbb61674ad4d9f6fff9c55c57773 (patch)
tree2236e5ca1e53a049923a6693e9c13b8ff73911e4 /gnu
parenta3437ed164f9a1bb13156e323a470a6f1dcb410e (diff)
gnu: python-statsd: Update to 4.0.1.
* gnu/packages/monitoring.scm (python-statsd): Update to 4.0.1. [build-system]: Swap to pyproject-build-system. [arguments] <test-flags>: Provide path to unit tests. [native-inputs]: Remove python-mock and python-nose; add python-pytest, python-setuptools, and python-wheel. Change-Id: I0d1c97ab2c4de76969d4da6c3af032dc0271ba0b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/monitoring.scm24
1 files changed, 15 insertions, 9 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 185387d96f..9813b5ca67 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -841,15 +841,21 @@ display resumes.
(define-public python-statsd
(package
(name "python-statsd")
- (version "3.3.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "statsd" version))
- (sha256
- (base32
- "07yxnlalvcglgwa9pjs1clwrmwx7a4575jai7q05jz3g4i6dprp3"))))
- (build-system python-build-system)
- (native-inputs (list python-mock python-nose))
+ (version "4.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "statsd" version))
+ (sha256
+ (base32 "0a6ilx68lxbynfm1slpaa87qs6mhrjm12bfjngvdma7y3fl3sxlr"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "statsd/tests.py")))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/jsocol/pystatsd")
(synopsis "Simple StatsD client")
(description "StatsD is a friendly front-end to Graphite. This package