summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-02 18:25:26 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:31 +0100
commitb632e15fe6c642682883f19f2c150c71b8279286 (patch)
tree337a15cd66340b9083c784594c04960f4725b720 /gnu
parent041fc97478a30b00c49a67e9fd75f18b0fb920f6 (diff)
gnu: python-botocore: Limit number of parallel test workers.
With 16 test workers the workers sometimes crash. * gnu/packages/python-xyz.scm (python-botocore)[arguments]: Use at most eight test workers. Change-Id: I8f752e7df576a47b8459c63d99d420d72861695d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7679196923..12b0cf3164 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20272,7 +20272,7 @@ browser from Python.")
(arguments
(list
#:test-flags
- #~(list "--numprocesses" (number->string (parallel-job-count))
+ #~(list "--numprocesses" (number->string (min (parallel-job-count) 8))
;; It strugles to find 'botocore'.
"--ignore" "tests/functional/leak/test_resource_leaks.py"
;; Tests require networking.