summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-02 22:58:59 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:31 +0100
commitb1229e5b44d7120baa0a64cd4a5e4dab3a63c04a (patch)
tree7c83424fe387b07058d589ddf7df0cdec3b1acfe /gnu
parentdb9b46ad53a5c3bfa2e4ba59af24611fddb853da (diff)
gnu: python-dnspython-1.16: Add missing inputs.
* gnu/packages/python-xyz.scm (python-dnspython-1.16)[arguments]: Add phase 'compatibility. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: I2d26d6607e4e376f204b790f14f38e067ebdc456
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 08ba162229..146ec338bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23088,7 +23088,26 @@ It supports TSIG authenticated messages and EDNS0.")
(sha256
(base32
"1yaw7irazy42n0kdhlk7wyg8ki34rxcnc5xbc1wfwy245b0wbxab"))))
- (native-inputs '())))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'compatibility
+ (lambda _
+ (substitute* "dns/namedict.py"
+ (("collections.MutableMapping")
+ "collections.abc.MutableMapping"))))
+ (add-after 'unpack 'patch-getprotobyname-calls
+ ;; These calls are problematic in the build environment as there is
+ ;; no /etc/protocols. This breaks the sanity-check phase of any
+ ;; package depnding on this one.
+ (lambda _
+ (substitute* "dns/rdtypes/IN/WKS.py"
+ (("socket.getprotobyname\\('tcp'\\)")
+ "6")
+ (("socket.getprotobyname\\('udp'\\)")
+ "17")))))))
+ (native-inputs (list python-pytest python-setuptools python-wheel))))
(define-public python-py3dns
(package