summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorgemmaro <[email protected]>2025-02-05 12:58:55 +0900
committerNicolas Goaziou <[email protected]>2025-02-22 15:24:19 +0100
commitacf544bc24472eb6befc418ef53713a6154220b9 (patch)
treea13a8709ea3f2507f1ea34cf2a271e2c782279c7 /gnu
parentfba707805665e4691215e2453f84f3d34439b4a1 (diff)
gnu: Add perl-lib-relative.
* gnu/packages/perl.scm (perl-lib-relative): New variable. Signed-off-by: Nicolas Goaziou <[email protected]> Change-Id: I24aa4db7bbd7be9145306ee85003567b011794ba
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2af5a84a78..5a6041800e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6796,6 +6796,26 @@ that aims to be compatible with the Uniforum message translations system as
implemented for example in GNU gettext.")
(license license:gpl3+)))
+(define-public perl-lib-relative
+ (package
+ (name "perl-lib-relative")
+ (version "1.002")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DB/DBOOK/lib-relative-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "12x7r08y04ml02wawhnk7j8zcb0ijd6vwy1yc0bnjh3w2qah4iz4"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/lib-relative")
+ (synopsis "Add paths relative to the current file to @code{@@INC}")
+ (description
+ "@code{lib::relative} module proposes a more straightforward method than
+adding a path to @code{@@INC}: take a path relative to the current
+file, absolutize it, and add it to @code{@@INC}.")
+ (license license:artistic2.0)))
+
(define-public perl-lingua-en-sentence
(package
(name "perl-lingua-en-sentence")