summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAshish SHUKLA <[email protected]>2025-02-05 10:14:32 +0100
committerMaxim Cournoyer <[email protected]>2025-02-09 00:10:48 +0900
commitab06abacc224136387a17fe514e368548a10ddce (patch)
tree4b70346d1da87477b8a6e1528a4069c0c4c26fb7 /gnu
parent2dc6dd6f7e6d4e08403d44a0492d0091fccba3da (diff)
gnu: emacs-magit: Update to 4.3.0.
* gnu/packages/emacs-xyz.scm (emacs-magit): Update to 4.3.0. [propagated-inputs]: Add emacs-llama, and remove emacs-dash. Change-Id: I7a7f24c066b01ceee24f9638f85105d4dc7827a6 Signed-off-by: Maxim Cournoyer <[email protected]> Reviewed-by: Cayetano Santos <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index aafa8b871d..84084bfe90 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1823,7 +1823,7 @@ before interacting with non-free LLMs.")
(define-public emacs-magit
(package
(name "emacs-magit")
- (version "4.2.0")
+ (version "4.3.0")
(source
(origin
(method git-fetch)
@@ -1832,7 +1832,7 @@ before interacting with non-free LLMs.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0zmrd6xlrvlr0i1a75xwlknmyx4hvpfxaqjkl61n12gd8598ji1j"))))
+ (base32 "1xz68154qmik4xs3ldl1gv87rb3famgd73k0174xbsr48d40ccyg"))))
(build-system emacs-build-system)
(arguments
(list
@@ -1897,7 +1897,7 @@ before interacting with non-free LLMs.")
(propagated-inputs
;; Note: the 'git-commit' and 'magit-section' dependencies are part of
;; magit itself.
- (list emacs-compat emacs-dash emacs-transient emacs-with-editor))
+ (list emacs-compat emacs-transient emacs-with-editor emacs-llama))
(home-page "https://magit.vc/")
(synopsis "Emacs interface for the Git version control system")
(description