summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <[email protected]>2024-05-27 23:08:36 +0200
committerLudovic Courtès <[email protected]>2024-08-31 10:45:23 +0200
commita19631329b949d8db9c86b70ea0ce0f1adba0124 (patch)
treee560eeb5d5681184543e2ef5831f5c66ca65d93c /gnu
parent5a32a345db7cc9f09fcbc1be22f6f5c9cca25c55 (diff)
gnu: Add texlive-gregoriotex-bin.
* gnu/packages/tex.scm (texlive-gregoriotex-bin): New variable. (texlive-gregoriotex)[propagated-inputs]: Add TEXLIVE-GREGORIOTEX-BIN. Change-Id: Ifcc2ed2eb193b822d72b6d6a349f522c18bfc1c2
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 583f26c78d..bd32f79bc4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15696,6 +15696,7 @@ logo.")
"0lnpq6rfdb6dg543cmbsm817ziim6arxnzxzbn0wn8i8aw681idr")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-gregoriotex-bin))
(home-page "https://ctan.org/pkg/gregoriotex")
(synopsis "Engraving gregorian chant scores")
(description
@@ -15705,6 +15706,52 @@ representation of a score) into a GregorioTeX file, which makes TeX able to
create a PDF of your score.")
(license license:gpl3)))
+(define-public texlive-gregoriotex-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-gregoriotex-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '())
+ (delete-other-directories "texk" '("gregorio"))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons "--enable-gregorio" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "texk/gregorio"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/gregorio"
+ (invoke "make" "install"))))))))
+ (native-inputs (list pkg-config))
+ (inputs (list texlive-libkpathsea))
+ (propagated-inputs '())
+ (home-page (package-home-page texlive-gregoriotex))
+ (synopsis "Binary for @code{texlive-gregoriotex}")
+ (description
+ "This package provides the binary for @code{texlive-gregoriotex}.")
+ (license (package-license texlive-gregoriotex))))
+
(define-public texlive-grotesq
(package
(name "texlive-grotesq")