summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2024-12-10 03:19:45 +0100
committerDanny Milosavljevic <[email protected]>2024-12-10 03:19:45 +0100
commit9e1ee5f77de1f03a1d75f1e0ad418e8fe0308dd9 (patch)
treeb9f44f23c763528c470866d671ff7825019c1006 /gnu
parent7efe81ea7df49edf0fb727ac575c955c3fed7e17 (diff)
gnu: Add python-columnize.
* gnu/packages/python-xyz.scm (python-columnize): New variable. Change-Id: Idf3ec4993b9d93d3d1e41e101dfdd76adff922fb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a98fdf3181..8a8c0a345c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21388,6 +21388,24 @@ Python implementation of the @code{wcwidth} and @code{wcswidth} C functions
specified in POSIX.1-2001 and POSIX.1-2008.")
(license license:expat)))
+(define-public python-columnize
+ (package
+ (name "python-columnize")
+ (version "0.3.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "columnize" version))
+ (sha256
+ (base32 "1clb3lfw694crq8m767q0yjaazkplcrbzdr9fr2w39hhndivhcd6"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/rocky/pycolumnize")
+ (synopsis "Format a simple (i.e. not nested) list into aligned columns.")
+ (description
+ "This package provides a way to format a simple (i.e. not nested) list
+into aligned columns.")
+ (license license:expat)))
+
(define-public python-chai
(package
(name "python-chai")