summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Wicki <[email protected]>2025-01-05 22:21:32 +0100
committerVagrant Cascadian <[email protected]>2025-01-05 15:38:49 -0800
commit8df34932ba0bf4a2cdfbcab88b956c2ee61052df (patch)
tree943021f0da96d20b3026dd50e35154e440ff5d37 /gnu
parent9c2761b589b0435b03d2dc859bd80ec14c0098bc (diff)
gnu: Fix whitespace issues in Rust package descriptions.
This mainly addresses `double-space after sentence end period' and `trailing white space' issues. * gnu/packages/crates-graphics.scm (rust-winit-0.30): Fix description. * gnu/packages/crates-io.scm (rust-arr-macro-0.1, rust-chan-0.1, rust-minimal-lexical-0.2): Fix description. Change-Id: I055c15df9b45c6f0bc3033edbf0afee4593e9383 Signed-off-by: Vagrant Cascadian <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-graphics.scm11
-rw-r--r--gnu/packages/crates-io.scm8
2 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 9ea45c6db6..9d7f44693a 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -5848,14 +5848,13 @@ from xml files.")
(home-page "https://github.com/rust-windowing/winit")
(synopsis "Window creation library")
(description
- "Winit is a window creation and management library. It can create
-windows and lets you handle events (for example: the window being
-resized, a key being pressed, a mouse movement, etc.) produced by
-window.
+ "Winit is a window creation and management library. It can create
+windows and lets you handle events (for example: the window being resized, a
+key being pressed, a mouse movement, etc.) produced by window.
Winit is designed to be a low-level brick in a hierarchy of libraries.
-Consequently, in order to show something on the window you need to use
-the platform-specific getters provided by winit, or another library.")
+Consequently, in order to show something on the window you need to use the
+platform-specific getters provided by winit, or another library.")
(license license:asl2.0)))
(define-public rust-winit-0.29
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c0da33ccfc..7716a24dc3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3038,7 +3038,7 @@ integers.")
("rust-proc-macro-hack" ,rust-proc-macro-hack-0.5))))
(home-page "https://github.com/JoshMcguigan/arr_macro")
(synopsis "Initialize arrays with ease")
- (description "Array macro helps initialize arrays. It is useful when
+ (description "Array macro helps initialize arrays. It is useful when
initializing large arrays (greater than 32 elements), or arrays of types which
do not implement the copy or default traits.")
(license (list license:expat license:asl2.0))))
@@ -12967,7 +12967,7 @@ chain, the first matching branch is the item that gets emitted.")
#:cargo-inputs (("rust-rand" ,rust-rand-0.3))))
(home-page "https://github.com/BurntSushi/chan")
(synopsis "DEPRECATED. Use crossbeam-channel instead")
- (description "DEPRECATED. Use crossbeam-channel instead.")
+ (description "DEPRECATED. Use crossbeam-channel instead.")
(license (list license:unlicense license:expat))))
(define-public rust-chalk-derive-0.75
@@ -45451,8 +45451,8 @@ library.")
(home-page "https://github.com/Alexhuszagh/minimal-lexical")
(synopsis "Float parsing conversion routines")
(description "This is a minimal version of rust-lexical, meant to allow
-efficient round-trip float parsing. Minimal-lexical implements a correct, fast
-float parser.")
+efficient round-trip float parsing. Minimal-lexical implements a correct,
+fast float parser.")
(license (list license:expat license:asl2.0))))
(define-public rust-minimp3-0.5