summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Langlois <[email protected]>2021-02-11 19:38:16 +0000
committerLudovic Courtès <[email protected]>2024-08-31 10:44:36 +0200
commit8c238042cb0f6144e49907b26a563ea29fbfa0b7 (patch)
treef48bcd90063a90afac9988be1a28a18851461a71 /gnu
parent3a930659a4958d99de5f3c647f4d8e1127b8a0ca (diff)
gnu: findutils-boot0: Re-enable most tests.
* gnu/packages/commencement.scm (findutils-boot0) [arguments]: Enable tests. Rename skip-fnmatch-test phase skip-problematic-tests. Only disable test-fnmatch on x86_64 and i686. Disable pthread tests on other platforms. Signed-off-by: Maxim Cournoyer <[email protected]> Modified-by: Maxim Cournoyer <[email protected]> Change-Id: I1efd62d98a27c3d9b878f37c890d6ff0ea6ea675
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm33
1 files changed, 19 insertions, 14 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index e44d84ca46..5b120915f2 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Maxim Cournoyer <[email protected]>
;;; Copyright © 2021 Chris Marusich <[email protected]>
;;; Copyright © 2021 Julien Lepiller <[email protected]>
+;;; Copyright © 2021 Pierre Langlois <[email protected]>
;;; Copyright © 2022 Ricardo Wurmus <[email protected]>
;;; Copyright © 2022, 2023 Ekaitz Zarraga <[email protected]>
;;;
@@ -2015,10 +2016,7 @@ exec " gcc "/bin/" program
,@(%bootstrap-inputs+toolchain)))
(arguments
`(#:implicit-inputs? #f
- ;; Ignore test failure in gnulib for armhf/aarch64.
- #:tests? ,(not (target-arm?))
#:guile ,%bootstrap-guile
-
;; The build system assumes we have done a mistake when time_t is 32-bit
;; on a 64-bit system. Ignore that for our bootstrap toolchain.
,@(substitute-keyword-arguments (package-arguments findutils)
@@ -2035,17 +2033,24 @@ exec " gcc "/bin/" program
,flags))
((#:phases phases '%standard-phases)
`(modify-phases ,phases
- ;; 'test-fnmatch' fails when using [email protected], due
- ;; to incorrect handling of the [:alpha:] regexp character
- ;; class. Ignore it.
- ,@(if (member (%current-system)
- '("x86_64-linux" "i686-linux"))
- '((add-before 'check 'skip-fnmatch-test
- (lambda _
- (substitute* "gnulib-tests/Makefile"
- (("^XFAIL_TESTS =")
- "XFAIL_TESTS = test-fnmatch ")))))
- '()))))))))
+ (add-before 'check 'skip-problematic-tests
+ (lambda _
+ ,(match (%current-system)
+ ;; 'test-fnmatch' fails when using [email protected], due
+ ;; to incorrect handling of the [:alpha:] regexp character
+ ;; class. Ignore it.
+ ((or "x86_64-linux" "i686-linux")
+ '(substitute* "gnulib-tests/Makefile"
+ (("^XFAIL_TESTS =")
+ "XFAIL_TESTS = test-fnmatch ")))
+ (_
+ ;; XXX: The pthread tests are known to fail at least on
+ ;; ARM; skip them.
+ '(substitute* "gnulib-tests/Makefile"
+ (("test-pthread\\$\\(EXEEXT\\)") "")
+ (("test-pthread-thread\\$\\(EXEEXT\\)") "")
+ (("test-pthread_sigmask1\\$\\(EXEEXT\\)") "")
+ (("test-pthread_sigmask2\\$\\(EXEEXT\\)") "")))))))))))))
(define file
(package