summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-02-22 02:13:24 +0100
committerDanny Milosavljevic <[email protected]>2025-02-22 15:26:10 +0100
commit86e7327de477982d0b7852d579e02c439c393ad8 (patch)
treebeb74220bc35c3cc216e69085de2535f52ceea97 /gnu
parent95c58847de530e5778aaa1030b68198433d929e1 (diff)
gnu: Add python-evemu.
* gnu/packages/linux.scm (python-evemu): New variable. Change-Id: I79e90ff2b151c9b56213f54768c9ad39ac7843fa
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c009a03529..49c03ee510 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -11384,3 +11384,42 @@ Linux input convention. Specifically, that allows you to use the D-pad
as a gamepad.")
(home-page "https://github.com/dkosmari/hid-wiimote-plus")
(license license:gpl2+)))
+
+(define-public python-evemu
+ (package
+ (name "python-evemu")
+ (version "2.7.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/libevdev/evemu")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sxf6v2wnajj9srlkfjfymjmmp4dlq73gzjcjmaw015a3c0xl029"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; would open device files
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "python/evemu/base.py"
+ (("\"libevdev.so\"")
+ (string-append "\"" (assoc-ref inputs "libevdev")
+ "/lib/libevdev.so\""))))))))
+ (native-inputs
+ (list asciidoc autoconf automake libtool docbook-xsl pkg-config
+ python-wrapper xmlto))
+ (inputs
+ (list libevdev))
+ (synopsis "Record and replay input device events")
+ (description "This package provides a way to record and replay device
+descriptions and events, making it possible to emulate input devices
+through the Linux kernel's input system. Emulated devices are for most
+practical purposes indistinguishable from real devices.
+
+It provides a command line program and also a Python library.")
+ (home-page "https://www.freedesktop.org/wiki/Evemu/")
+ (license license:gpl3)))