summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEvgeny Pisemsky <[email protected]>2025-02-07 19:51:05 +0000
committerSharlatan Hellseher <[email protected]>2025-02-08 18:04:08 +0000
commit8010d73407205a63f2f27e719007ee9975ea8602 (patch)
tree02cee1623135eba5aa7fb90d8c3ea57566525790 /gnu
parent05516fcb24799d00947751a434dd797f3fbb9d64 (diff)
gnu: Add python-pytest-snapshot.
* gnu/packages/check.scm (python-pytest-snapshot): New variable. Change-Id: Ie3126b6233f53640adb4dcb90e4d348eaf9ffbff Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 8d494fe09a..aac500f443 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2024 David Elsing <[email protected]>
;;; Copyright © 2024 Eric Bavier <[email protected]>
;;; Copyright © 2024 Markku Korkeala <[email protected]>
+;;; Copyright © 2025 Evgeny Pisemsky <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -659,6 +660,36 @@ tests at the granularity of individual test cases, which can be run in
parallel and on multiple machines.")
(license license:expat))))
+(define-public python-pytest-snapshot
+ (package
+ (name "python-pytest-snapshot")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-snapshot" version))
+ (sha256
+ (base32 "1wxp9pv5yqpj3fk450ld1mjhhdxyvssgi6gqxyghz1iyphx3q0f7"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Skip failing test. Related upstream issue:
+ ;; <https://github.com/joseph-roitman/pytest-snapshot/issues/71>.
+ #:test-flags #~(list "-k" "not test_assert_match_failure_bytes")))
+ (native-inputs
+ (list python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-pytest))
+ (home-page "https://github.com/joseph-roitman/pytest-snapshot")
+ (synopsis "Pytest plugin for snapshot testing")
+ (description
+ "This package provides a plugin for snapshot testing with pytest. It can
+be used to test that the value of an expression does not change
+unexpectedly.")
+ (license license:expat)))
+
(define-public python-testfixtures
(package
(name "python-testfixtures")