summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authoraurtzy <[email protected]>2025-03-06 03:44:52 -0500
committerMaxim Cournoyer <[email protected]>2025-03-09 16:14:06 +0900
commit7da79dde4d75fa924e2512c30aaf25dbd936768c (patch)
treed782b57b6d2481d5ba2566a8ceef7d0420c6e746 /gnu
parent0aabe127171ac22b9b67a21ead47c3395696117a (diff)
gnu: gnome-shell-extension-gsconnect: Patch shebangs with gjs.
The 'patch-shebangs phase does not handle shebangs of the form "/usr/bin/env -S", so we manually patch them to fix a not-found error. * gnu/packages/gnome-xyz.scm (gnome-shell-extension-gsconnect): [arguments]<#:phases>: Add 'patch-gjs-shebangs phase to patch shebangs using "/usr/bin/env -S" to execute gjs. Change-Id: I6b84474e4976484f1203b7cf78fe5e882694cd22 Signed-off-by: Maxim Cournoyer <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome-xyz.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 359dc757fd..09e73a9c0a 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -761,6 +761,19 @@ faster window switching.")
"gtk_update_icon_cache: false")
(("update_desktop_database: true")
"update_desktop_database: false"))))
+ ;; TODO: Remove after 'patch-shebangs is fixed to handle '/usr/bin/env -S'
+ ;; shebangs (see bug#74450).
+ (add-after 'unpack 'patch-gjs-shebangs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (substitute* file
+ (("^#!/usr/bin/env -S gjs.*$")
+ (string-append "#!" (which "gjs") " -m"))))
+ '("installed-tests/minijasmine"
+ "src/gsconnect-preferences"
+ "src/service/nativeMessagingHost.js"
+ "src/service/daemon.js"
+ "webextension/gettext.js"))))
(add-before 'configure 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(let ((gapplication (search-input-file inputs "/bin/gapplication"))