summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2020-01-16 22:00:12 +0200
committerEfraim Flashner <[email protected]>2020-01-16 22:00:12 +0200
commit6e02ef79f574855db28e23d891db690925119e7b (patch)
treed2cd530fbd44bf92ae14498ccdfa6928e02969b6 /gnu
parentef201cfee7daca9250ecd416ba255966ecd9194a (diff)
gnu: translate-shell: Fix emacs install phase.
* gnu/packages/dictionaries.scm (translate-shell)[arguments]: Update the 'emacs-install phase to install the .el files into the correct folder.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/dictionaries.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 1aa54d9167..af6cef71d3 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <[email protected]>
-;;; Copyright © 2016, 2017, 2018 Efraim Flashner <[email protected]>
+;;; Copyright © 2016, 2017, 2018, 2020 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Sou Bunnbu <[email protected]>
;;; Copyright © 2017, 2018, 2019 Nicolas Goaziou <[email protected]>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <[email protected]>
@@ -283,8 +283,7 @@ and a Python library.")
(add-after 'install 'emacs-install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (dest (string-append out "/share/emacs/site-lisp/guix.d/"
- ,name "-" ,version))
+ (dest (string-append out "/share/emacs/site-lisp"))
(emacs (string-append (assoc-ref inputs "emacs") "/bin/emacs")))
(install-file "google-translate-mode.el" dest)
(emacs-generate-autoloads ,name dest)))))