summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-03 14:48:04 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:33 +0100
commit6d040c972397e911db7f69fb50cf711e0d3835d2 (patch)
treed2f77323fc49d1ed54ea342e04e4ecf5e721f51b /gnu
parentadef506aca11877d7545f81a099bf94dde193128 (diff)
gnu: python-flask-wtf: Update to 1.2.2.
* gnu/packages/python-web.scm (python-flask-wtf): Update to 1.2.2. [arguments]: Remove. [build-system]: Use pyproject-build-system. [propagated-inputs]: Add python-flask. [native-inputs]: Add python-hatchling. Change-Id: I850217cc3c2bda3c4c48688a3cf924303ce0251a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 998d8a5936..aadf76102a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4915,25 +4915,19 @@ Django middleware.")
(define-public python-flask-wtf
(package
(name "python-flask-wtf")
- (version "1.0.1")
+ (version "1.2.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Flask-WTF" version))
(sha256
(base32
- "1jd614662r6ifh4svs8zfwm4k8bal5z3n6pq607bas8gxrpmrzil"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
+ "0sv6hjva1fdizb7sr46230pplx8qz8rnb4bxrfy71xbc8cgfxlkr"))))
+ (build-system pyproject-build-system)
(propagated-inputs
- (list python-flask python-itsdangerous python-wtforms))
+ (list python-flask python-flask python-itsdangerous python-wtforms))
(native-inputs
- (list python-pytest))
+ (list python-hatchling python-pytest))
(home-page "https://github.com/lepture/flask-wtf")
(synopsis "Simple integration of Flask and WTForms")
(description "Flask-WTF integrates Flask and WTForms, including CSRF, file