summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 13:33:54 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:34 +0800
commit6bfa202069747e23dafdec544f63290d120b7812 (patch)
tree31bee8e346d2770641bce0591c6a12c2d65c8475 /gnu
parentb50c64b5e552c0f24558acb217a69b9a2c0c68f7 (diff)
gnu: xfce4-eyes-plugin: Update to 4.6.2.
* gnu/packages/xfce.scm (xfce4-eyes-plugin): Update to 4.6.2. [source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: I97c8114fad77038d2cbad0afdd23d9a49f557cb8
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 666807d291..a870dcdce0 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1716,24 +1716,24 @@ core or CPU.")
(define-public xfce4-eyes-plugin
(package
- (name "xfce4-eyes-plugin")
- (version "4.6.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
- "xfce4-eyes-plugin/"
- (version-major+minor version)
- "/xfce4-eyes-plugin-" version ".tar.bz2"))
- (sha256
- (base32
- "092kmv2i0flg3zg622q0id70mz1kvlz27y12i5y3nfdsi1fz03xd"))))
+ (name "xfce4-eyes-plugin")
+ (version "4.6.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/panel-plugins/"
+ name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wwfxhaxp6r8g4jvj5ax7a3djh4q896ilxdfdcx6n67qzs5ksq8h"))))
(build-system gnu-build-system)
(native-inputs
- (list intltool pkg-config))
+ (list xfce4-dev-tools))
(inputs
(list libxfce4ui xfce4-panel))
- (home-page
- "https://goodies.xfce.org/projects/panel-plugins/xfce4-eyes-plugin")
+ (home-page "https://docs.xfce.org/panel-plugins/xfce4-eyes-plugin/")
(synopsis "Display a pair of eyes for the Xfce panel")
(description "Eyes is a toy Xfce panel plugin that adds eyes which
watch your every step.")