summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-10 09:48:53 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-30 15:06:35 +0000
commit6ac0c594287367ba0f168b915bd332cf9e9d46c7 (patch)
tree753bb6c2c067af6f7d3ef6dc9a9bbe08d8d4ee6a /gnu
parentddbdb5419354c7563726c72f847e9e93869d35b8 (diff)
gnu: Add julia-interfaces.
* gnu/packages/julia-xyz.scm (julia-interfaces): New variable. Change-Id: Ia0dc3903460f4fa87a0649e404dacea33c0f8f04
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3a55d626ef..8e9b4397c8 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3490,6 +3490,31 @@ each one has a fixed size. Currently support inline strings from 1 byte up to
255 bytes.")
(license license:expat)))
+(define-public julia-interfaces
+ (package
+ (name "julia-interfaces")
+ (version "0.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rafaqz/Interfaces.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1g765wzqc16pxrr3kqcbq0b2n1w51mwaxffrv4yjn1mvr607y6xf"))))
+ (build-system julia-build-system)
+ (native-inputs
+ (list julia-aqua))
+ (propagated-inputs
+ (list julia-documenter))
+ (home-page "https://github.com/rafaqz/Interfaces.jl")
+ (synopsis "Macros to define and implement interfaces")
+ (description
+ "This package provides macros for defining the required behaviours of
+Julia interfaces, and stating that an object implements them.")
+ (license license:expat)))
+
(define-public julia-interpolations
(package
(name "julia-interpolations")