summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJames Smith <[email protected]>2025-01-24 18:41:19 -0700
committerNicolas Goaziou <[email protected]>2025-03-01 11:21:22 +0100
commit6863b689eb15c451620d5f8db308ec73957c1275 (patch)
tree64981df447a19b4b5288792657ab78c8c72fd4d0 /gnu
parent97c465b0f63345ba3d7543ca544e050234943be1 (diff)
gnu: Add embree-2.
* gnu/packages/graphics.scm: (embree-2): New variable. Change-Id: I2b2143b4d93c402ba940d408280ef1b37ab552ea Signed-off-by: Nicolas Goaziou <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7b87c39e88..97a40293cb 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2023 Eric Bavier <[email protected]>
;;; Copyright © 2023, 2024 Artyom V. Poptsov <[email protected]>
;;; Copyright © 2024 Ivan Vilata-i-Balaguer <[email protected]>
+;;; Copyright © 2024 James Smith <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -492,6 +493,30 @@ applications.")
(base32
"1kcvz7g6j56anv9zjyd3gidxl46vipw0gg82lns12m45cd43iwxm"))))))
+(define-public embree-2
+ (package/inherit embree
+ (version "2.17.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/RenderKit/embree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name (package-name embree) version))
+ (sha256
+ (base32 "19v60zdfix33c772x6dzmhsarhafsns8qy7c2ysqr7a9j16whgql"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments embree)
+ ((#:configure-flags configure-flags)
+ #~(append (list "-DEMBREE_MAX_ISA=NONE" "-DEMBREE_TUTORIALS=OFF")
+ #$configure-flags))))
+ (inputs (modify-inputs (package-inputs embree)
+ (replace "tbb" tbb-2020)))
+ ;; Embree requires SSE2 support, so build only for x86-based architectures.
+ (supported-systems (list "i686-linux" "x86_64-linux"))
+ (description (string-append (package-description embree) "
+
+Please note that this version requires a processor with SSE2 support."))))
+
(define-public openvdb
(package
(name "openvdb")