summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-18 00:03:45 +0000
committerSharlatan Hellseher <[email protected]>2024-12-30 15:07:40 +0000
commit61884eb3b6287c5b1fd8c8ca7c198a97bf09c0e7 (patch)
tree0f666bbca88a923d499e2997dc7a44a9deffad2d /gnu
parent41db7fd4cef31c1950ca17d4d1ba9f25666098ab (diff)
gnu: python-webbpsf: Update to 1.5.0.
* gnu/packages/astronomy.scm (python-webbpsf): Update to 1.5.0. [arguments]<test-flags>: Enable 2 tests after NumPy has been updated. Skip one more test requiring network access. Change-Id: I54fb11fdbbb1c19bed39e00a9c1036ed09e03387
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 01341b52cb..3805ee5cee 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -6442,26 +6442,26 @@ between image and reference catalogs. Currently only aligning images with
(define-public python-webbpsf
(package
(name "python-webbpsf")
- (version "1.4.0")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "webbpsf" version))
(sha256
- (base32 "1084vbk2q3kybxgvh8f2zbsi2w2z8zapsfjkgd6km4yhwqv1wl4a"))))
+ (base32 "0aad817lh2llld9wmb4mvdnncz916niw2apnhip8gc78fi1imfri"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
#~(list "--numprocesses" (number->string (parallel-job-count))
- "-k" (string-append
- ;; Test requiring network access
- "not test_monthly_trending_plot_auto_opdtable"
- " and not test_monthly_trending_plot_opdtable_param"
- " and not test_delta_wfe_around_time"
- ;; Newer NumPy is required
- " and not test_nircam_errors"
- " and not test_all_detectors"))
+ "-k"
+ ;; Tests requiring network access.
+ (string-join
+ (list "not test_delta_wfe_around_time"
+ "test_get_webbpsf_data_path_invalid"
+ "test_monthly_trending_plot_auto_opdtable"
+ "test_monthly_trending_plot_opdtable_param")
+ " and not "))
#:phases
#~(modify-phases %standard-phases
(add-before 'check 'set-env