summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <[email protected]>2023-06-09 14:58:50 +0000
committerSharlatan Hellseher <[email protected]>2025-02-11 16:04:52 +0000
commit5ff5a2b2cf5ff5d191848fcf060d79d6ffc13c11 (patch)
treedd76282adb26de05d89f40ad8d376e1dd1729066 /gnu
parenta7d7a1ec0b56f985c22b80056040a5e2ec012a80 (diff)
gnu: Add python-imagehash.
* gnu/packages/python-science.scm (python-imagehash): New variable. Co-authored-by: Sharlatan Hellseher <[email protected]> Signed-off-by: Sharlatan Hellseher <[email protected]> Change-Id: Ie773b4504d97ac2678e0776a27eb661d909fed47
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index bcd16724b1..1f4cdb239a 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -253,6 +253,52 @@ numerical software for solving convex second-order cone programs (SOCPs).")
formulas for Python.")
(license license:expat)))
+(define-public python-imagehash
+ (package
+ (name "python-imagehash")
+ (version "4.3.1")
+ (source
+ (origin
+ (method git-fetch) ;no tests in PyPI
+ (uri (git-reference
+ ;; It's an effective and maintained fork of
+ ;; <https://github.com/bunchesofdonald/photohash> project, which
+ ;; has the latest release in 2016.
+ (url "https://github.com/JohannesBuchner/imagehash")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lw9lxzrzy9s5v3xc35vmh97hlyavnla087fp19k77va6v8vbjjf"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-numpy
+ python-pillow
+ python-pywavelets
+ python-scipy))
+ (home-page "https://github.com/JohannesBuchner/imagehash")
+ (synopsis "Perceptual Image Hashing library")
+ (description
+ "This package implements a functinoality to tell whether two images look
+nearly identical. The image hash algorithms (average, perceptual, difference,
+wavelet) analyse the image structure on luminance (without color information).
+The color hash algorithm analyses the color distribution and black & gray
+fractions (without position information).
+
+Features:
+@itemize
+@item average hashing
+@item perceptual hashing
+@item difference hashing
+@item wavelet hashing
+@item HSV color hashing (colorhash)
+@item crop-resistant hashing
+@end itemize")
+ (license license:bsd-2)))
+
(define-public python-osqp
(package
(name "python-osqp")