summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <[email protected]>2025-02-09 01:52:26 +0000
committerAndreas Enge <[email protected]>2025-02-10 14:27:57 +0100
commit58dce798cb43a6fdec48f9e5bf6045a7193cf125 (patch)
treec34cd400e803d01bae5327530b59c576e9f4a794 /gnu
parent7010eda3659849016ab6d41c84213d3fc0c94b65 (diff)
gnu: singular: Use G-Expressions.
* gnu/packages/algebra.scm (singular)[arguments]: Use G-Expressions. Move below build-system. Change-Id: I4253b8a9a9cd3b7d2b7492853323d1e8c4fbec4e Signed-off-by: Andreas Enge <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 759f44b84e..68f6684254 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -617,6 +617,10 @@ matrices, and polynomials over the integers and over finite fields.")
(base32
"0625541pxxhs7789i3ddf5fm1pqvf1kyljyaii41djg9j12cdhbc"))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list (string-append "--with-ntl="
+ #$(this-package-input "ntl")))))
(native-inputs
(list doxygen graphviz perl))
(inputs
@@ -627,10 +631,6 @@ matrices, and polynomials over the integers and over finite fields.")
ntl
python-2
readline))
- (arguments
- `(#:configure-flags
- (list (string-append "--with-ntl="
- (assoc-ref %build-inputs "ntl")))))
(synopsis "Computer algebra system for polynomial computations")
(description
"Singular is a computer algebra system for polynomial computations,