summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-06 21:08:16 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:40 +0000
commit5547fbe7d23f91bf6d433cde4c585697c0cfa8c9 (patch)
tree08f9abf3b11de2575611d6237eb0775a880a16bf /gnu
parent82ec069b4f67880d1c2fec7a7814f37255d1192c (diff)
gnu: go-github-com-docker-go-connections: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-docker-go-connections): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I30348ea1bf48d3f6929035d9a25141c6cfe86b47
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm33
-rw-r--r--gnu/packages/golang.scm33
2 files changed, 33 insertions, 33 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 8ae530e46c..02bd307acd 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1553,6 +1553,39 @@ Data Representation (XDR) standard protocol as specified in RFC
4506 (obsoletes RFC 1832 and RFC 1014) in pure Go.")
(license license:isc)))
+(define-public go-github-com-docker-go-connections
+ (package
+ (name "go-github-com-docker-go-connections")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/go-connections")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0svfa9g4xvbn87l5kiww1jkijmci9g5821wjp81xz1rfp13cqrk8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/docker/go-connections"
+ #:test-flags
+ #~(list "-skip"
+ (string-join
+ ;; Unable to verify certificate 1: x509: certificate signed by
+ ;; unknown authority.
+ (list "TestConfigClientExclusiveRootPools"
+ "TestConfigServerExclusiveRootPools")
+ "|"))))
+ (home-page "https://github.com/docker/go-connections")
+ (synopsis "Networking library for Go")
+ (description
+ "This package provides a library to work with network connections in the
+Go language. In particular it provides tools to deal with network address
+translation (NAT), proxies, sockets, and transport layer security (TLS).")
+ (license license:asl2.0)))
+
(define-public go-github-com-dpotapov-go-spnego
(package
(name "go-github-com-dpotapov-go-spnego")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 643c511b0c..23e89a63f6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2558,39 +2558,6 @@ store, and deliver content. It contains Docker Registry 2.0 and libraries
to interact with distribution components.")
(license license:asl2.0))))
-(define-public go-github-com-docker-go-connections
- (package
- (name "go-github-com-docker-go-connections")
- (version "0.5.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/docker/go-connections")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0svfa9g4xvbn87l5kiww1jkijmci9g5821wjp81xz1rfp13cqrk8"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/docker/go-connections"
- #:test-flags
- #~(list "-skip"
- (string-join
- ;; Unable to verify certificate 1: x509: certificate signed by
- ;; unknown authority.
- (list "TestConfigClientExclusiveRootPools"
- "TestConfigServerExclusiveRootPools")
- "|"))))
- (home-page "https://github.com/docker/go-connections")
- (synopsis "Networking library for Go")
- (description
- "This package provides a library to work with network connections in the
-Go language. In particular it provides tools to deal with network address
-translation (NAT), proxies, sockets, and transport layer security (TLS).")
- (license license:asl2.0)))
-
(define-public go-github-com-aarzilli-golua
(let ((commit "03fc4642d792b1f2bc5e7343b403cf490f8c501d")
(revision "0"))