summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-09 21:19:15 +0000
committerSharlatan Hellseher <[email protected]>2025-02-09 21:19:20 +0000
commit45943e0979457c63c8678b41f5ae5f80c770d55a (patch)
treed5525258dbbe9ec026e01d8ee26d407fd6b745d0 /gnu
parent5754f6a0976fb06d9bf1702b9b98e991d7b4dbc0 (diff)
gnu: python-munch: Update to 4.0.0.
* gnu/packages/python-xyz.scm (python-munch): Update to 4.0.0. [build-system]: Swap to pyproject-build-system. [propagated-inputs]: Remove python-six. [native-inputs]: Remove python-pbr; add python-astroid, python-setuptools, and python-wheel. Change-Id: Ie2c8698ecac7990c70f479b8e35dc138ce0343bb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3739e055ca..a1b47ca5f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9542,17 +9542,20 @@ methods is arguably lacking. This package provides drop-in wrappers
(define-public python-munch
(package
(name "python-munch")
- (version "2.5.0")
+ (version "4.0.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "munch" version))
- (sha256
- (base32
- "1lnvlic9g68hcmgdnv5bzp0nx2bf1kjclj54gx0s7nyl4ipmywrd"))))
- (build-system python-build-system)
- (native-inputs (list python-pbr python-pytest))
- (propagated-inputs (list python-six))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "munch" version))
+ (sha256
+ (base32
+ "0d928bdzm0d9s9f058xa72pywps2zjdgvhrp9rm22qqj8r8v2b2l"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-astroid
+ python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/Infinidat/munch")
(synopsis "Dot-accessible dictionary")
(description "Munch is a dot-accessible dictionary similar to JavaScript