summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2023-04-17 16:14:52 +0300
committerEfraim Flashner <[email protected]>2023-04-30 12:35:56 +0300
commit45363fdb172f93ebbddbdeeef876988c6c108fdd (patch)
tree6d12feeed6637f409fc7b4e7aaf71f3d155e7d2b /gnu
parent0fbf12a96a7934c76f70c4a3d59f847bd0c25d92 (diff)
gnu: ulogd: Build with mariadb.
* gnu/packages/linux.scm (ulogd)[inputs]: Remove mysql. Add mariadb:dev. [arguments]: Adjust configure-flags accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 29213f5fd1..14262e194a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Mark H Weaver <[email protected]>
;;; Copyright © 2015 Federico Beffa <[email protected]>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <[email protected]>
-;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2022 Efraim Flashner <[email protected]>
+;;; Copyright © 2015-2018, 2020, 2022, 2023 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Christine Lemmer-Webber <[email protected]>
;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2016, 2017 Alex Kost <[email protected]>
@@ -8070,7 +8070,7 @@ receiving to-be-logged packets from the kernel nfnetlink_log subsystem
libpcap
jansson
postgresql
- mysql
+ (list mariadb "dev")
zlib
openssl))
(arguments
@@ -8078,7 +8078,7 @@ receiving to-be-logged packets from the kernel nfnetlink_log subsystem
#~(list (string-append "--with-pgsql="
(assoc-ref %build-inputs "postgresql"))
(string-append "--with-mysql="
- (assoc-ref %build-inputs "mysql")))
+ (assoc-ref %build-inputs "mariadb")))
#:phases
#~(modify-phases %standard-phases
(add-after 'install 'install-doc