summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <[email protected]>2024-05-27 19:24:03 +0200
committerLudovic Courtès <[email protected]>2024-08-31 10:45:23 +0200
commit448c3b17372fcb1fa430785ba5ee3af9819a83f4 (patch)
tree868cc22499409b36cbe552a3e8ad21e67e01527b /gnu
parentb95b7ee0178af9898045a1956c49f89ff58e43c3 (diff)
gnu: Add texlive-afm2pl-bin.
* gnu/packages/tex.scm (texlive-afm2pl-bin): New variable. (texlive-afm2pl)[propagated-inputs]: Add TEXLIVE-AFM2PL-BIN. Change-Id: Ibfb1eb61f5202f98d105907052dd6e6c4e5b7642
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1ab2b1964d..7c4b3d040e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1891,6 +1891,7 @@ the TeX Gyre bundle do not need this support.")
"19llzzr4kmmyf7l18ngx1rhaqaqvgm3md924m4dxcv7nmrvga2b2")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-afm2pl-bin))
(home-page "https://ctan.org/pkg/afm2pl")
(synopsis "Convert AFM to TeX property list (@file{.pl}) metrics")
(description
@@ -1900,6 +1901,51 @@ a @file{.tfm} (TeX Font Metric) file. It normally preserves kerns and
ligatures, but also offers additional control over them.")
(license license:gpl2)))
+(define-public texlive-afm2pl-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-afm2pl-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '())
+ (delete-other-directories "texk" '("afm2pl"))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons "--enable-afm2pl" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "texk/afm2pl"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/afm2pl"
+ (invoke "make" "install"))))))))
+ (native-inputs (list pkg-config))
+ (inputs (list texlive-libkpathsea))
+ (propagated-inputs '())
+ (synopsis "Binary for @code{texlive-afm2pl}")
+ (description
+ "This package provides the binary for @code{texlive-afm2pl}.")
+ (license (package-license texlive-afm2pl))))
+
(define-public texlive-afparticle
(package
(name "texlive-afparticle")