summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2024-07-24 21:23:10 +0200
committerLudovic Courtès <[email protected]>2024-08-31 10:45:43 +0200
commit1c322552dd47dbefdd740e2a6750e310840e9244 (patch)
tree9295aefeea5aab9497825ca8a3c9b7c6782c8058 /gnu
parentf9f49a70f21d24fbddab839b281978a963cff797 (diff)
gnu: inkscape: Update conditional patch.
* gnu/packages/inkscape.scm (inkscape)[arguments]: Fix substitution expression to avoid syntax error. Change-Id: I00a65848d2b95795a7a59c4c5164b14faefcf2b7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/inkscape.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index aa33a0a4a3..cb32b7d38f 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <[email protected]>
;;; Copyright © 2014, 2016 Mark H Weaver <[email protected]>
-;;; Copyright © 2016, 2018 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2016, 2018, 2024 Ricardo Wurmus <[email protected]>
;;; Copyright © 2017, 2020 Marius Bakke <[email protected]>
;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2020, 2021, 2022, 2024 Maxim Cournoyer <[email protected]>
@@ -191,7 +191,8 @@ endif()~%~%"
;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035539888
;; According to upstream, this is a false positive.
(substitute* "testfiles/rendering_tests/CMakeLists.txt"
- (("test-use") "#test-use"))
+ (("add_rendering_test\\(test-use" all)
+ (string-append "#" all)))
;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035539888
;; Allegedly a precision error in the gamma.
(substitute* "testfiles/cli_tests/CMakeLists.txt"