summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorterramorpha <[email protected]>2021-12-15 17:01:02 -0500
committerLeo Famulari <[email protected]>2021-12-15 17:40:52 -0500
commit18b1497673b92b6a0947839f9757a561a77d0d5f (patch)
treeedbfa7bc958093b7413c76074c06f3c66f70b9af /gnu
parentb574ccc45371eb5c1df3089be783fedb39273e33 (diff)
gnu: xdot: Build with harfbuzz.
This fixes a crash when launching xdot. * gnu/packages/graphviz.scm (xdot)[inputs]: Add harfbuzz. [arguments]: Add harfbuzz to the GI_TYPELIB_PATH wrapper in the 'wrap' phase. Signed-off-by: Leo Famulari <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphviz.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index c4dfd4965b..ab39e49d7d 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Pjotr Prins <[email protected]>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <[email protected]>
;;; Copyright © 2021 Giacomo Leidi <[email protected]>
+;;; Copyright © 2021 Justin Veilleux <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -346,12 +347,14 @@ Graphviz and LaTeX.")
(assoc-ref inputs "gtk+") "/lib/girepository-1.0"
":" (assoc-ref inputs "pango") "/lib/girepository-1.0"
":" (assoc-ref inputs "gdk-pixbuf") "/lib/girepository-1.0"
- ":" (assoc-ref inputs "atk") "/lib/girepository-1.0")))
+ ":" (assoc-ref inputs "atk") "/lib/girepository-1.0"
+ ":" (assoc-ref inputs "harfbuzz") "/lib/girepository-1.0")))
`("PATH" ":" prefix
(,(dirname (search-input-file inputs "bin/dot"))))))))))
(inputs
(list atk
librsvg
+ harfbuzz
graphviz
gtk+
python-pycairo