summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2019-02-01 22:42:49 +0200
committerEfraim Flashner <[email protected]>2019-02-04 08:07:47 +0200
commit1009e6e7ecc00b72a51778e90b0212ccc33bfa7a (patch)
treed380f2d5ef362a869deddd4dd524c0104e876f4a /gnu
parent28317d499034b00cf1f08a9efd39bd2bc3425b19 (diff)
gnu: [email protected]: Build with binutils-gold on armhf and aarch64.
* gnu/packages/golang.scm ([email protected])[native-inputs]: Add binutils-gold for armhf-linux and aarch64-linux.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cedfabe5bf..7dbe27c2ee 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2018 Efraim Flashner <[email protected]>
+;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Matthew Jordan <[email protected]>
;;; Copyright © 2016 Andy Wingo <[email protected]>
;;; Copyright © 2016 Ludovic Courtès <[email protected]>
@@ -399,6 +399,10 @@ in the style of communicating sequential processes (@dfn{CSP}).")
#t)))))))
(native-inputs
`(("go" ,go-1.4)
+ ,@(match (%current-system)
+ ((or "armhf-linux" "aarch64-linux")
+ `(("gold" ,binutils-gold)))
+ (_ `()))
,@(package-native-inputs go-1.4)))
(supported-systems %supported-systems)))