summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorWiktor Żelazny <[email protected]>2023-07-09 16:21:39 +0200
committerNicolas Goaziou <[email protected]>2025-02-22 15:51:45 +0100
commit0d4ded941ec9ec4443e98d498416e5ae70069fcd (patch)
tree632b102b0a3d5a2b8f2916342763ccc51087889b /gnu
parenta17961a4dcf5339391df15cba137d9849eae4618 (diff)
gnu: Add python-sphinx-autoapi.
* gnu/packages/sphinx.scm (python-sphinx-autoapi): New variable. Signed-off-by: Nicolas Goaziou <[email protected]> Change-Id: Iac37c9b67927b147969db0707679c0916c52efc1
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sphinx.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 13a1701e0a..01c154d35e 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1488,3 +1488,31 @@ Sphinx documentation.")
"This package provides a Bootstrap-based Sphinx theme from the PyData
community.")
(license license:bsd-3)))
+
+(define-public python-sphinx-autoapi
+ (package
+ (name "python-sphinx-autoapi")
+ (version "2.0.1") ;higher versions require Sphinx >= 5.2.0
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx-autoapi" version))
+ (sha256
+ (base32
+ "1fmss6ihjjx22nmjzy7qiapj1f2b86gd1vycn3zg8lh8q9l7kx6d"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-sphinx python-wheel))
+ (propagated-inputs
+ (list python-astroid
+ python-jinja2
+ python-pyyaml
+ python-sphinx
+ python-unidecode))
+ (home-page "https://github.com/readthedocs/sphinx-autoapi")
+ (synopsis "Sphinx API documentation generator")
+ (description
+ "Sphinx AutoAPI is a Sphinx extension for generating complete
+API documentation without needing to load, run, or import the project being
+documented. In contrast to the traditional Sphinx @code{autodoc}, which
+requires manual authoring and uses code imports, AutoAPI finds and generates
+documentation by parsing source code.")
+ (license license:expat)))