summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-03 08:52:18 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:31 +0100
commit0328ebfec3f8ed76b04f61a2c6624b7e27ad9d98 (patch)
treefae5949ac2e1ca55ffa1aa69c0328d13a5a1d1da /gnu
parented2aa2d8342be095c267a5d1e57fad54d17a8434 (diff)
gnu: Add python-joserfc.
* gnu/packages/python-web.scm (python-joserfc): New variable. Change-Id: If4c297022059eb2cc40d8d467ef47e3b8a2aa6eb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4e7545b86e..543832de46 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1804,6 +1804,35 @@ JSON Web Algorithms (JWA) - collectively can be used to encrypt and/or sign
content using a variety of algorithms.")
(license license:expat)))
+(define-public python-joserfc
+ (package
+ (name "python-joserfc")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "joserfc" version))
+ (sha256
+ (base32 "11m600bmj70bp96wxhwvyj4d57w0zahzq3vic7s4a4k85pl7nl64"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; No module named 'Crypto'
+ '(list "--ignore=tests/jwe/test_chacha20.py"
+ ;; Deprecation warnings are not raised.
+ "-k" (string-append "not test_guess_bytes_key"
+ " and not test_guess_callable_key"
+ " and not test_guess_str_key"))))
+ (propagated-inputs (list python-cryptography))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (home-page "https://github.com/authlib/joserfc")
+ (synopsis "Python library for JOSE RFCs")
+ (description
+ "This package provides a Python library for JOSE RFCs, including JWS,
+JWE, JWK, JWA, and JWT.")
+ (license license:bsd-3)))
+
(define-public python-jwcrypto
(package
(name "python-jwcrypto")