summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-09 12:32:23 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:48 +0000
commit027356f66c0a392861d3fa4bd15e26b09480f47c (patch)
treece449e1f1a37b2adffbfd41dc55074784a70219a /gnu
parent297f3f279a54c9337ccd55dc04d4ba6574ef4f77 (diff)
gnu: go-github-com-twpayne-go-vfs: Rename variable.
* gnu/packages/configuration-management.scm * gnu/packages/golang-xyz.scm (go-github-com-twpayne-go-vfs): Rename variable to go-github-com-twpayne-go-vfs-v5 to reflect go.mod import path. [arguments] <import-path>: Adjust as seen in go.mod for the current version. (go-github-com-twpayne-go-vfs-1.0.1) [arguments] <import-path>: Adjust as seen in go.mod for the current version. * gnu/packages/configuration-management.scm (chezmoi) [native-inputs]: Remove go-github-com-twpayne-go-vfs, add go-github-com-twpayne-go-vfs-1.0.1. Change-Id: Ifa1ae0e12795248820c86db106146a45f4bbbe2d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/configuration-management.scm2
-rw-r--r--gnu/packages/golang-xyz.scm13
2 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index 3482e327f7..36450ad70c 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -100,7 +100,7 @@
go-github-com-spf13-viper
go-github-com-stretchr-testify
go-github-com-twpayne-go-shell
- go-github-com-twpayne-go-vfs
+ go-github-com-twpayne-go-vfs-1.0.1
go-github-com-twpayne-go-vfsafero
go-github-com-twpayne-go-xdg-v3
go-github-com-zalando-go-keyring
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a6afad9a9f..b73f19ca0b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -13239,9 +13239,9 @@ supported by the time package
"Package @code{shell} returns a user's shell across multiple platforms.")
(license license:expat)))
-(define-public go-github-com-twpayne-go-vfs
+(define-public go-github-com-twpayne-go-vfs-v5
(package
- (name "go-github-com-twpayne-go-vfs")
+ (name "go-github-com-twpayne-go-vfs-v5")
(version "5.0.4")
(source
(origin
@@ -13255,7 +13255,7 @@ supported by the time package
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/twpayne/go-vfs"
+ #:import-path "github.com/twpayne/go-vfs/v5"
#:phases
#~(modify-phases %standard-phases
;; XXX: Replace when go-build-system supports nested path.
@@ -13275,7 +13275,7 @@ supported by the time package
;; XXX: For chezmoi 1.8.10, remove it when updated.
(define-public go-github-com-twpayne-go-vfs-1.0.1
- (hidden-package (package (inherit go-github-com-twpayne-go-vfs)
+ (hidden-package (package (inherit go-github-com-twpayne-go-vfs-v5)
(name "go-github-com-twpayne-go-vfs")
(version "1.0.1")
(source
@@ -13286,7 +13286,10 @@ supported by the time package
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1if2wfdwl3h8v8kgrgywkwcjafcz7hynq8ikr52s11qf2n0w3gny")))))))
+ (base32 "1if2wfdwl3h8v8kgrgywkwcjafcz7hynq8ikr52s11qf2n0w3gny"))))
+ (arguments
+ (list
+ #:import-path "github.com/twpayne/go-vfs")))))
(define-public go-github-com-urfave-cli
(package