summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <[email protected]>2025-03-08 20:40:40 +0100
committerNicolas Goaziou <[email protected]>2025-03-08 20:40:40 +0100
commitddf96eeb79919b24f00e19bf35c8fa9699638986 (patch)
tree739e255778d28bdec87d13b875175acc079ffe82 /gnu/packages
parent6fb29b0e4a6a869953529d26c5fc57840cdc3473 (diff)
gnu: plover: Also run on Wayland.
* gnu/packages/stenography.scm (plover)[arguments]: Add a call to xhost in order to let Plover run on XWayland. [inputs]: Add xhost. Change-Id: I9700b4fe401bd8cda31e952baaff96b32dd978a9
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/stenography.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/stenography.scm b/gnu/packages/stenography.scm
index 67f9754652..8a1e9e84f7 100644
--- a/gnu/packages/stenography.scm
+++ b/gnu/packages/stenography.scm
@@ -35,7 +35,8 @@
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
- #:use-module (gnu packages wxwidgets))
+ #:use-module (gnu packages wxwidgets)
+ #:use-module (gnu packages xorg))
(define-public python-plover-stroke
(package
@@ -88,7 +89,17 @@
`("QT_PLUGIN_PATH" prefix
(,(search-input-directory inputs "/lib/qt5/plugins/")))
`("LD_LIBRARY_PATH" prefix
- (,(string-append #$(this-package-input "dbus") "/lib")))))))))
+ (,(string-append #$(this-package-input "dbus") "/lib"))))))
+ (add-after 'wrap-executable 'run-on-xwayland
+ ;; By default, Plover won't run on Wayland, and requires a call to
+ ;; xhost to run on XWayland.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((plover (string-append #$output "/bin/plover"))
+ (xhost (search-input-file inputs "bin/xhost")))
+ (substitute* plover
+ (("exec .*" line)
+ (string-append xhost " +si:localuser:$USER\n"
+ line)))))))))
(native-inputs
(list python-babel
python-mock
@@ -107,7 +118,8 @@
python-rtf-tokenize
python-wcwidth
python-xlib
- qtsvg-5))
+ qtsvg-5
+ xhost))
(home-page "https://www.openstenoproject.org/plover/")
(synopsis "Stenography engine")
(description