summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFelix Gruber <[email protected]>2022-01-01 18:34:14 +0000
committerLeo Famulari <[email protected]>2022-01-01 23:22:59 -0500
commita83dc5022b70d4ee96741311553c65bc636625ae (patch)
tree62d59db7e0a2377766293183733683973be081c0 /gnu/packages
parent6f83a503af908fdd732765e1327c6afb8f53f3d2 (diff)
gnu: widelands: Fix build against boost 1.77.
Widelands fails to build with boost 1.77 due to a missing include in one of Wideland's header files that was previously indirectly included by boost 1.76. * gnu/packages/patches/widelands-add-missing-map-include.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/games.scm (widelands)[source]: Add patch. Signed-off-by: Leo Famulari <[email protected]>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm5
-rw-r--r--gnu/packages/patches/widelands-add-missing-map-include.patch28
2 files changed, 31 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d4653c912e..c61dafc7a0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -61,7 +61,7 @@
;;; Copyright © 2021 Stefan Reichör <[email protected]>
;;; Copyright © 2021 Greg Hogan <[email protected]>
;;; Copyright © 2021 David Pflug <[email protected]>
-;;; Copyright © 2021 Felix Gruber <[email protected]>
+;;; Copyright © 2021, 2022 Felix Gruber <[email protected]>
;;; Copyright © 2021 Solene Rapenne <[email protected]>
;;; Copyright © 2021 Noisytoot <[email protected]>
;;; Copyright © 2021 Petr Hodina <[email protected]>
@@ -5135,7 +5135,8 @@ tactics.")
(patches
;; Use system Minizip. Patch is provided by Debian, and discussed
;; upstream at <https://github.com/widelands/widelands/issues/399>.
- (search-patches "widelands-system-wide_minizip.patch"))))
+ (search-patches "widelands-system-wide_minizip.patch"
+ "widelands-add-missing-map-include.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/patches/widelands-add-missing-map-include.patch b/gnu/packages/patches/widelands-add-missing-map-include.patch
new file mode 100644
index 0000000000..633731bea2
--- /dev/null
+++ b/gnu/packages/patches/widelands-add-missing-map-include.patch
@@ -0,0 +1,28 @@
+From 316eaea209754368a57f445ea4dd016ecf8eded6 Mon Sep 17 00:00:00 2001
+From: matthiakl <[email protected]>
+Date: Sat, 14 Aug 2021 19:24:08 +0200
+Subject: [PATCH] Added missing direct incude (#5025)
+
+---
+This patch is from
+https://github.com/widelands/widelands/pull/5025
+which has been merged after the release of Widelands 1.0.
+
+ src/network/bufferedconnection.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/network/bufferedconnection.h b/src/network/bufferedconnection.h
+index fe974b9e..7e1ecf87 100644
+--- a/src/network/bufferedconnection.h
++++ b/src/network/bufferedconnection.h
+@@ -20,6 +20,7 @@
+ #ifndef WL_NETWORK_BUFFEREDCONNECTION_H
+ #define WL_NETWORK_BUFFEREDCONNECTION_H
+
++#include <map>
+ #include <memory>
+ #include <mutex>
+ #include <thread>
+--
+2.30.2
+