summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEvgeny Pisemsky <[email protected]>2025-02-11 23:39:04 +0300
committerSharlatan Hellseher <[email protected]>2025-02-11 21:39:15 +0000
commit777cff3194bc05a236234066fbb9365c68dc6a44 (patch)
treed4376679e58c406f757923a5ce4388a2d7154596 /gnu/packages
parentf5aa303cc09b266e33db37beb6e6b7b6af79b870 (diff)
gnu: Add python-awesomeversion.
* gnu/packages/python-xyz.scm (python-awesomeversion): New variable. Change-Id: I090abfacf7f73ab14ea1e0347211de2a60675128 Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e4f4fa6887..fcdc4387b3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -433,6 +433,31 @@ libraries such as @code{trio}, as well as any custom @code{async} event
loop.")
(license license:expat)))
+(define-public python-awesomeversion
+ (package
+ (name "python-awesomeversion")
+ (version "24.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ludeeus/awesomeversion")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kvzhhd2ah0sadlsp5xs3qbiknixq4xwhk3yb6kmhcdl2zcbi4cn"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-poetry-core
+ python-pytest
+ python-pytest-snapshot))
+ (home-page "https://github.com/ludeeus/awesomeversion")
+ (synopsis "Create and compare version objects")
+ (description
+ "This package provides a way to make anything a version object, and
+compare against a vast section of other version formats.")
+ (license license:expat)))
+
(define-public python-awkward-cpp
(package
(name "python-awkward-cpp")