summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-02-20 19:24:25 +0200
committerEfraim Flashner <[email protected]>2025-02-20 19:36:01 +0200
commit71122981cb6136473227c5c21d6d69cbe13f1907 (patch)
treedc36a91a53018ac02baf175200365e7433b963b8 /gnu/packages
parentadeb7e4d1fa332e0b145fa6e84b0c51c70a66b6a (diff)
gnu: libblockdev: Allow building on riscv64-linux.
* gnu/packages/disk.scm (libblockdev)[inputs]: Only add multipath-tools on systems which are supported. Change-Id: Ie79a78bfdf0147589494a0a1a39e4ff45fefbbee
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/disk.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index b429e40bd2..c19d94760c 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Mathieu Lirzin <[email protected]>
;;; Copyright © 2015 Mark H Weaver <[email protected]>
;;; Copyright © 2016, 2018–2022 Tobias Geerinckx-Rice <[email protected]>
-;;; Copyright © 2016, 2019-2021, 2023 Efraim Flashner <[email protected]>
+;;; Copyright © 2016, 2019-2021, 2023, 2025 Efraim Flashner <[email protected]>
;;; Copyright © 2016, 2023 Janneke Nieuwenhuizen <[email protected]>
;;; Copyright © 2016 Roel Janssen <[email protected]>
;;; Copyright © 2016, 2017 Marius Bakke <[email protected]>
@@ -1249,6 +1249,9 @@ to create devices with respective mappings for the ATARAID sets discovered.")
(inputs
(append
(cons cryptsetup (libcryptsetup-propagated-inputs))
+ (if (supported-package? multipath-tools)
+ (list multipath-tools)
+ '())
(list bcache-tools
btrfs-progs
dosfstools
@@ -1264,7 +1267,6 @@ to create devices with respective mappings for the ATARAID sets discovered.")
libyaml
lvm2
mdadm
- multipath-tools
ndctl
nss
ntfs-3g