summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <[email protected]>2024-05-27 23:56:13 +0200
committerLudovic Courtès <[email protected]>2024-08-31 10:45:24 +0200
commit4c99d369fa8f6c927986ac2214519158b274779d (patch)
tree6b4002d63a03a83d5edf6f861654b56ae0a3a3b8 /gnu/packages
parent5cb19b93b1893cd1bbd07526e1883080321d17e2 (diff)
gnu: Add texlive-bibtexu-bin.
* gnu/packages/tex.scm (texlive-bibtexu-bin): New variable. (texlive-bibtexu)[propagated-inputs]: Add TEXLIVE-BIBTEXu-BIN. Change-Id: Iafd01d42aee35030e30a761a2f8f42b8908e82b0
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 335734118f..5db8c2dd4b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33799,6 +33799,7 @@ order are controlled by an external configuration file.")
"19bp8wn0ssz7gczxp0imbpgi1zwz9x3ya67f072rjzg2zmfpphqg")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-bibtexu-bin))
(home-page "https://ctan.org/pkg/bibtexu")
(synopsis "BibTeX variant supporting Unicode (UTF-8), via ICU")
(description
@@ -33806,6 +33807,34 @@ order are controlled by an external configuration file.")
supported via the ICU library.")
(license license:gpl3+)))
+(define-public texlive-bibtexu-bin
+ (package
+ (inherit texlive-bibtex8-bin)
+ (name "texlive-bibtexu-bin")
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bibtex8-bin)
+ ((#:configure-flags flags)
+ #~(cons* "--enable-bibtexu"
+ "--disable-bibtex8"
+ (delete "--enable-bibtex8"
+ (delete "--disable-bibtexu" #$flags))))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (delete 'skip-bibtexu-test)
+ (add-after 'unpack 'skip-bibtex8-test
+ ;; This package does not build "bibtex8" binary; the test below
+ ;; is therefore bound to fail. Skip that part.
+ (lambda _
+ (substitute* "texk/bibtex-x/tests/bibtex8u-mem.test"
+ (("\\./bibtex8 .*") "exit 0\n"))))))))
+ (native-inputs (list pkg-config))
+ (inputs (list icu4c texlive-libkpathsea))
+ (home-page (package-home-page texlive-bibtexu))
+ (synopsis "Binary for @code{texlive-bibtexu}")
+ (description
+ "This package provides the binary for @code{texlive-bibtexu}.")
+ (license (package-license texlive-bibtexu))))
+
(define-public texlive-bundledoc
(package
(name "texlive-bundledoc")