summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEkaitz Zarraga <[email protected]>2025-03-11 00:12:44 +0100
committerEkaitz Zarraga <[email protected]>2025-03-11 16:55:53 +0100
commit3bf7a0e8c431abfcba51806ee2a3eea9e0865472 (patch)
tree51c64ae214e67700ab38793fb345da84f41ce0da /gnu/packages
parentd9a25a19e4e225c38d231915647826e66aca4498 (diff)
gnu: ngspice: Add X11 support (plots) to ngspice
* gnu/packages/engineering.scm (libngspice)[inputs]: Remove libxau. (ngspice)[inputs]: Add libxau and libx11. [arguments]<#:configure-flags>: Add --with-x and --enable-rpath. <#:tests?>: Disable because it tests against a running X server. Change-Id: I00e8766947d2c5dfea20d42e3eb02b0e9e15879a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/engineering.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index c63e332121..625ddc8030 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2263,7 +2263,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
#:configure-flags #~(list "--enable-openmp" "--enable-cider"
"--enable-xspice" "--with-ngshared")))
(native-inputs (list bison flex))
- (inputs (list libxaw openmpi))
+ (inputs (list openmpi))
(home-page "https://ngspice.sourceforge.net/")
(synopsis "Mixed-level/mixed-signal circuit simulator")
(description
@@ -2282,19 +2282,16 @@ an embedded event driven algorithm.")
(inherit libngspice)
(name "ngspice")
(arguments
- (substitute-keyword-arguments
- (strip-keyword-arguments
- (list #:tests?)
- (package-arguments libngspice))
+ (substitute-keyword-arguments (package-arguments libngspice)
+ ;; Tests require a X server running, so we keep them disabled
((#:configure-flags flags)
- #~(cons "--with-readline=yes"
- (delete "--with-ngshared"
- #$flags)))
+ #~(cons* "--enable-rpath" "--with-x" "--with-readline=yes"
+ (delete "--with-ngshared" #$flags)))
((#:phases phases)
#~(modify-phases #$phases
(delete 'delete-scripts)))))
(native-inputs (list perl))
- (inputs (list libngspice readline))))
+ (inputs (list libngspice readline libxaw libx11))))
(define trilinos-serial-xyce
;; Note: This is a Trilinos containing only the packages Xyce needs, so we