summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <[email protected]>2024-05-08 14:42:36 +0200
committerLudovic Courtès <[email protected]>2024-08-31 10:45:19 +0200
commit2402df01a62966ff7065c32821d01ea35f5bd5c1 (patch)
tree5735c6b97571e9ebe3bb2902411f563f8f00dac5 /gnu/packages
parent220546810830422f8ec3e6a4145fec85429914a1 (diff)
gnu: texlive-libkpathsea: Fix TEXMFCACHE location.
* gnu/packages/tex.scm (texlive-libkpathsea)[arguments]<#:phases>: Set TEXMFCACHE in "texmf.cnf" to "$HOME/.texliveYYYY/texmf-var/" instead of "{$GUIX_TEXMF}", which creates a "{" directory in the current working directory. * guix/build/texlive-build-system.scm (set-texmfvar): New function. (%standard-phases): Add SET-TEXMFVAR phase. Change-Id: Idff2fd5279e12d35683c863528aac3b5efa9b22b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 70af0ee83f..104fa11493 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2020 Vincent Legoll <[email protected]>
;;; Copyright © 2020, 2021 Paul Garlick <[email protected]>
;;; Copyright © 2021, 2022 Maxim Cournoyer <[email protected]>
-;;; Copyright © 2021-2023 Nicolas Goaziou <[email protected]>
+;;; Copyright © 2021-2024 Nicolas Goaziou <[email protected]>
;;; Copyright © 2021 Leo Le Bouter <[email protected]>
;;; Copyright © 2021 Xinglu Chen <[email protected]>
;;; Copyright © 2021 Ivan Gankevich <[email protected]>
@@ -224,6 +224,10 @@
"TEXMF = {$GUIX_TEXMF}\n")
(("\\$SELFAUTOLOC(/share/texmf-dist/web2c)" _ suffix)
(string-append #$output suffix))
+ ;; Ignore system-wide cache. Use local one, by default
+ ;; "$HOME/.texliveYYYY/texmf-var/".
+ (("^TEXMFCACHE = .*")
+ "TEXMFCACHE = $TEXMFVAR\n")
;; Don't truncate lines.
(("^error_line = .*$") "error_line = 254\n")
(("^half_error_line = .*$") "half_error_line = 238\n")