summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <[email protected]>2024-05-27 18:51:50 +0200
committerLudovic Courtès <[email protected]>2024-08-31 10:45:23 +0200
commit18325381539888df5295bed5565e232f3c383eb0 (patch)
tree84cbb2a97bfe7261ce6913904e9f4a894c37741e /gnu/packages
parentda343b4c4c1518a2221a6af8843282b5d22cdaca (diff)
gnu: Add texlive-aleph-bin.
* gnu/packages/tex.scm (texlive-aleph-bin): New variable. (texlive-aleph)[propagated-inputs]: Add TEXLIVE-ALEPH-BIN. Change-Id: I77bb0bc1943f43d57f801404317568c438cb2f50
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ebf5fe3fa7..d23f039a74 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2099,7 +2099,8 @@ number styles are available.")
(build-system texlive-build-system)
(arguments (list #:create-formats #~(list "aleph")))
(propagated-inputs
- (list texlive-cm
+ (list texlive-aleph-bin
+ texlive-cm
texlive-hyphen-base
texlive-knuth-lib
texlive-lambda
@@ -2112,6 +2113,31 @@ number styles are available.")
extensions of TeX, itself developed for e-TeX.")
(license license:gpl3+)))
+(define-public texlive-aleph-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-aleph-bin")
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons* "--disable-web2c"
+ "--enable-aleph"
+ (delete "--disable-aleph"
+ (delete "--enable-web2c" #$flags))))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/web2c"
+ (invoke "make" "aleph")
+ (install-file "aleph" (string-append #$output "/bin")))))))))
+ (native-inputs (list pkg-config))
+ (home-page (package-home-page texlive-aleph))
+ (synopsis "Binary for @code{texlive-aleph}")
+ (description
+ "This package provides the binary for @code{texlive-aleph}.")
+ (license (package-license texlive-aleph))))
+
(define-public texlive-alfaslabone
(package
(name "texlive-alfaslabone")