summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorAbhishek Cherath <[email protected]>2024-04-20 09:44:03 -0400
committerLiliana Marie Prikler <[email protected]>2025-03-02 20:31:34 +0100
commit075ff9f60b3b899ab9d2f51c08b9c3528a190a4e (patch)
tree96b02f94f6f2ce6571ca631635f27d9410ea4b77 /gnu/packages/webkit.scm
parent5f0c0bc59a34b7e2554c003f8dd42e8591ffdae0 (diff)
gnu: webkitgtk: Expose more paths to bubblewrap sandbox.
Provide access to system locale path and to paths from GUIX_LOCPATH, LOCPATH, and LIBVA_DRIVERS_PATH to the Bubblewrap sandbox in order to silence GTK locale warnings and enable hardware accelerated video. * gnu/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch: Add @dridir@ and @localedir@ to bubblewrap gtk sandbox. Add paths from GUIX_LOCPATH, LOCPATH, and LIBVA_DRIVERS_PATH to bubblewrap gtk sandbox. * gnu/packages/webkit.scm (webkitgtk) [arguments]: In the 'configure-bubblewrap-store-directory' phase, also supply system locale to webkitgtk-adjust-bubblewrap-paths.patch template. Change-Id: I6be0c473ebaa6c04ebb00a2b4afcae2c89396e4f Signed-off-by: Maxim Cournoyer <[email protected]>
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 4593528e62..d5b0801a7b 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019 Marius Bakke <[email protected]>
;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <[email protected]>
;;; Copyright © 2022, 2023 Efraim Flashner <[email protected]>
+;;; Copyright © 2024 Abhishek Cherath <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -191,7 +192,12 @@ engine that uses Wayland for graphics output.")
(let ((store-directory (%store-directory)))
(substitute*
"Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp"
- (("@storedir@") store-directory)))))
+ (("@storedir@") store-directory)
+ ;; This silences GTK locale errors.
+ ;; Unfortunately, simply bind mounting /run/current-system
+ ;; does not work since it leads to weird issues
+ ;; with symlinks that confuse bubblewrap.
+ (("@localedir@") "/run/current-system/locale")))))
(add-after 'unpack 'do-not-disable-new-dtags
;; Ensure the linker uses new dynamic tags as this is what Guix
;; uses and validates in the validate-runpath phase.