summaryrefslogtreecommitdiff
path: root/gnu/packages/toys.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-13 09:08:36 +0000
committerSharlatan Hellseher <[email protected]>2025-02-13 09:49:48 +0000
commit32f49d6c0767d2d2423750bd8c91e15d1018a851 (patch)
tree621e9577a6bc257113af8d36d2951be356b367d7 /gnu/packages/toys.scm
parent590d24d6d9baeabd16ad370465c20e7b89b5a951 (diff)
gnu: filters: Use G-Expressions.
* gnu/packages/toys.scm (filters): Use G-Expressions. [arguments]: Remove trailing #t from lambda. Change-Id: Iced42b1c99cf5c8fe7193f39f3cd9d44593792a6
Diffstat (limited to 'gnu/packages/toys.scm')
-rw-r--r--gnu/packages/toys.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index bd7db83083..e096e52da7 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -163,22 +163,22 @@ This package provides just the utilities and no quotes.")
""))))))
(build-system gnu-build-system)
(arguments
- `(#:parallel-build? #f ;y.tab.h fails otherwise
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "prefix=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'respect-prefix
- (lambda _
- (substitute* "Makefile"
- (("/usr/games")
- "$(prefix)/bin/")
- (("/usr")
- "$(prefix)"))
- #t)))
- #:tests? #f)) ; no test suite
+ (list
+ #:parallel-build? #f ; y.tab.h fails otherwise
+ #:tests? #f ; no test suite
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "prefix=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'respect-prefix
+ (lambda _
+ (substitute* "Makefile"
+ (("/usr/games")
+ "$(prefix)/bin/")
+ (("/usr")
+ "$(prefix)")))))))
(native-inputs
(list bison flex))
(inputs