summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-27 16:24:10 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:22 +0200
commite161b62314f94bff70139c64a75ff0d9cf9fb656 (patch)
tree68038177ee5f87f8216deaa63eedb11f128a56ec /gnu/packages/tex.scm
parentf8da4c59d5166dc3b5f1822873e2271900da63f9 (diff)
gnu: Add texlive-uptex-bin.
* gnu/packages/tex.scm (texlive-uptex-bin): New variable. (texlive-uptex)[propagated-inputs]: Add TEXLIVE-UPTEX-BIN. Change-Id: I540cea7f648f0e11aaf59000aeff763823f94b2f
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm49
1 files changed, 44 insertions, 5 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9691fdeb71..8669bcfdcd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -37322,18 +37322,57 @@ and e-upTeX.")
texlive-plain
texlive-ptex-base
texlive-uptex-base
+ texlive-uptex-bin
texlive-uptex-fonts))
(home-page "https://ctan.org/pkg/uptex")
(synopsis "Unicode version of pTeX")
(description
- "upTeX is an extension of pTeX, using UTF-8 input and producing UTF-8 output.
-It was originally designed to improve support for Japanese, but is also useful
-for documents in Chinese and Korean. It can process Chinese simplified,
-Chinese traditional, Japanese, and Korean simultaneously, and can also process
-original LaTeX with @code{\\inputenc@{utf8@}} and Babel
+ "upTeX is an extension of pTeX, using UTF-8 input and producing UTF-8
+output. It was originally designed to improve support for Japanese, but is
+also useful for documents in Chinese and Korean. It can process Chinese
+simplified, Chinese traditional, Japanese, and Korean simultaneously, and can
+also process original LaTeX with @code{\\inputenc@{utf8@}} and Babel
(Latin/Cyrillic/Greek etc.) by switching its @code{\\kcatcode} tables.")
(license license:bsd-3)))
+(define-public texlive-uptex-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-uptex-bin")
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(delete "--enable-web2c" #$flags))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'build 'build-binaries
+ (lambda _
+ (with-directory-excursion "texk/web2c"
+ (for-each (lambda (target) (invoke "make" target))
+ '("euptex" "upbibtex" "updvitype" "upmpost"
+ "uppltotf" "uptex" "uptftopl" "wovp2ovf")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/web2c"
+ (let ((bin (string-append #$output "/bin")))
+ (for-each (lambda (f) (install-file f bin))
+ '("euptex" "upbibtex" "updvitype"
+ "upmpost" "uppltotf" "uptex" "uptftopl"
+ "wovp2ovf"))
+ (with-directory-excursion bin
+ (for-each symlink
+ '("upmpost" "upmpost")
+ '("r-upmpost" "updvitomp")))))))))))
+ (native-inputs (list pkg-config))
+ (inputs
+ (modify-inputs (package-inputs texlive-bin)
+ (append cairo gmp mpfr texlive-libptexenc)))
+ (home-page (package-home-page texlive-uptex))
+ (synopsis "Binaries for @code{texlive-uptex}")
+ (description
+ "This package provides the binaries for @code{texlive-uptex}.")
+ (license (package-license texlive-uptex))))
+
(define-public texlive-uptex-fonts
(package
(name "texlive-uptex-fonts")